Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

FDXM instrument is disabled with IB?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    FDXM instrument is disabled with IB?

    Hello NT Team,
    I’m trying to trade FDXM (mini dax future) but I can’t get the symbol data through IB Gateway, but I know I subscribed Eurex data on my IB account .

    When I checked the log NT8 says that I should contact you. btw in the instrument list FDXM / IB connection is disabled.

    I also subscribed to Kinetick on my dev. System and here I can get the data through Kinetick.
    Any suggestion to help fix the problem is highly appreciated.

    #2
    Hello,

    Thank you for your post.

    There is currently a known limitation with Interactive Brokers in NinjaTrader that only the FDXM or FDAX instrument may be used at one time, and not both at the same time. By default, the FDXM will be disabled. If you would like to use this instead of the FDAX, please use these steps.

    From the Control Center, navigate to Tools -> Instruments.
    Search for FDXM.
    Once found, click FDXM and select "edit".
    Scroll down to the Symbol Mapping for Interactive Brokers and delete the "-disabled" part of this Parameter.
    Click "OK" to save your changes.
    Once this is done, please disable the FDAX instrument.

    From the Control Center, navigate to Tools -> Instruments.
    Search for FDAX.
    Once found, click FDAX and select "edit".
    Scroll down to the Symbol Mapping for Interactive Brokers and add in the "-disabled" just after the instrument name. This will look almost exactly like the FDXM instrument did before.
    Click "OK" to save your changes.

    We look forward to assisting further.
    Marco G.NinjaTrader Customer Service

    Comment


      #3
      Hi fernlicht,
      With the combination of NinjaTrader and IB, you can only trade either the FDAX of the FDXM because they share the SAME(!) symbol at IB.
      This can be fixed with a trick in other platforms (enabling to trade both in parallel), but to my knowledge not with Ninja.
      I assume, the FDAX is currently activitated in your Ninja platform and the FDXM is deactivated. That's at least the default setting.
      To check and adjust, please click on Tools -> Instruments -> Select FDAX and then FDXM.
      Currenty settings are likely as follows [25 stands for point value of 25 = FDAX, 5 stands for point value of 5 = FDXM]:
      DAX|||25
      DAX-disabled|||5
      Please change to
      DAX-disabled|||25
      DAX|||5
      Let me know if this works for you.
      NT-Roland

      Comment


        #4
        Thanks for the quick answers and clarification

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by Kicks.Spin, Today, 05:16 PM
        0 responses
        6 views
        0 likes
        Last Post Kicks.Spin  
        Started by MrBrunotte, Today, 12:52 PM
        0 responses
        20 views
        0 likes
        Last Post MrBrunotte  
        Started by AndyM, Today, 12:22 PM
        0 responses
        21 views
        0 likes
        Last Post AndyM
        by AndyM
         
        Started by Carter, Today, 12:07 PM
        0 responses
        7 views
        0 likes
        Last Post Carter
        by Carter
         
        Started by llanqui, Today, 12:05 PM
        0 responses
        7 views
        0 likes
        Last Post llanqui
        by llanqui
         
        Working...
        X