Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

"The requested instrument BTC is disabled. Please contact platformsupport"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by NinjaTrader_RyanS View Post
    Hello,

    Does the issue persist after restarting your platform? If so, are you also unable to load this instrument to a Superdom or Basic entry order window?
    The mapping you have listed is the correct mapping for the BTC contract with IB.

    I look forward to hearing from you.

    yes the error message is there both after restarting NT8 and then also when opening BTC 05-21 to a Superdom or Basic entry order window.

    Comment


      #17
      any update on this problem ?

      It should be easy to reproduce and see if you get the same problem on your side ?

      Comment


        #18
        Hello,


        Resetting your instruments should resolve this item.

        To reset your instruments, please take the steps below.
        1. First, disconnect from any data providers by navigating to the Control Center > Connections menu, and left-click on “disconnect” that appears to the right when hovering your mouse over any active connection
        2. Next, reset your instruments by navigating to the Control Center > Tools > Database Management
        3. In the Database Management window, under the “Update instruments” section, ensure that “General properties”, "Futures expiries" and “Symbol mappings” options are checked and then click Update
        4. Lastly, restart NinjaTrader for the changes to occur

        Please let us know if we may be of further assistance.
        Ryan S.NinjaTrader Customer Service

        Comment


          #19
          Originally posted by NinjaTrader_RyanS View Post
          Hello,


          Resetting your instruments should resolve this item.

          To reset your instruments, please take the steps below.
          1. First, disconnect from any data providers by navigating to the Control Center > Connections menu, and left-click on “disconnect” that appears to the right when hovering your mouse over any active connection
          2. Next, reset your instruments by navigating to the Control Center > Tools > Database Management
          3. In the Database Management window, under the “Update instruments” section, ensure that “General properties”, "Futures expiries" and “Symbol mappings” options are checked and then click Update
          4. Lastly, restart NinjaTrader for the changes to occur

          Please let us know if we may be of further assistance.

          Do I lose or erase any of my existing historical price data on any of my existing instruments by resetting the instruments ?

          if it doesnt affect my historical price data then I will be able to proceed.

          Comment


            #20
            Originally posted by NinjaTrader_RyanS View Post
            Hello,


            Resetting your instruments should resolve this item.

            To reset your instruments, please take the steps below.
            1. First, disconnect from any data providers by navigating to the Control Center > Connections menu, and left-click on “disconnect” that appears to the right when hovering your mouse over any active connection
            2. Next, reset your instruments by navigating to the Control Center > Tools > Database Management
            3. In the Database Management window, under the “Update instruments” section, ensure that “General properties”, "Futures expiries" and “Symbol mappings” options are checked and then click Update
            4. Lastly, restart NinjaTrader for the changes to occur

            Please let us know if we may be of further assistance.
            Ok made a backup file of everything and then updated the instruments like you instructed.

            With the symbol mapping changes that i got from the update, now it is working and I am getting data for btc 05-21 in NT8 but I ran into another weird problem.

            I also checked with the superdom and BTC 05-21 and I am getting this error message in the logs : "Instrument BTC 05-21 Globex is not enabled to receive real time data. Please add the instrument to your IB account data subscriptions."

            But I am in fact subscribed to a real-time CME data subscription with Interactive brokers. Also I checked with other CME contracts by putting them in the superdom and I get the same message with every other instrument like ES and NQ in the NT8 logs panel when i put them in the superdom.

            Everything else is working with these contracts in NT8 though, from the superdom to the real time chart in NT8 and I am receiving real time data on all CME contracts in both NT8 and IB TWS. So it is clear that my Interactive Brokers real-time CME subscription is working properly.

            Why does NT8 gives me that error message in NT8 logs when I put CME contracts into the superdom ?

            Before this, I never noticed the error message since the superdom seems to be working fine so I never checked the error logs when I used the superdom before.


            Thank you for your help.
            Last edited by qewcool; 05-04-2021, 07:02 PM.

            Comment


              #21
              There is the SFT-2074 which should solve the issue. You can vote for that on my post:

              https://ninjatrader.com/support/foru...on#post1153266

              Thanks,
              Klaus

              Comment


                #22
                Originally posted by qewcool View Post

                I ran into another weird problem.

                I also checked with the superdom and BTC 05-21 and I am getting this error message in the logs : "Instrument BTC 05-21 Globex is not enabled to receive real time data. Please add the instrument to your IB account data subscriptions."

                But I am in fact subscribed to a real-time CME data subscription with Interactive brokers. Also I checked with other CME contracts by putting them in the superdom and I get the same message with every other instrument like ES and NQ in the NT8 logs panel when i put them in the superdom.

                Everything else is working with these contracts in NT8 though, from the superdom to the real time chart in NT8 and I am receiving real time data on all CME contracts in both NT8 and IB TWS. So it is clear that my Interactive Brokers real-time CME subscription is working properly.

                Why does NT8 gives me that error message in NT8 logs when I put CME contracts into the superdom ?

                Before this, I never noticed the error message since the superdom seems to be working fine so I never checked the error logs when I used the superdom before.


                any update on this ?

                seems like a L1 vs L2 real time sub ? NT8 giving this error if the real time subscription is L1 instead of L2 when using superdom to initiate order entries ?

                Comment


                  #23

                  There is currently a known limitation with Interactive Brokers in NinjaTrader that only the MBT or BTC instrument may be used at one time and not both at the same time. By default, the BTC will be disabled. If you would like to use this instead of the MBT, please use these steps.

                  From the Control Center, navigate to Tools -> Instruments.
                  • Search for BTC.
                  • Once found, click BTC and select "edit".
                  • Scroll down to the Symbol Mapping for Interactive Brokers and delete the "-disabled" part of this Parameter.
                  • Click "OK" to save your changes.

                  Once this is done, please disable the MBT instrument.
                  • From the Control Center, navigate to Tools -> Instruments. Search for MBT.
                  • Once found, click MBT and select "edit".
                  • Scroll down to the Symbol Mapping for Interactive Brokers and add in the "-disabled" just after the instrument name. This will look almost exactly like the BTC instrument did before.
                  • Click "OK" to save your changes.

                  Please let us know if we may be of further assistance.
                  Ryan S.NinjaTrader Customer Service

                  Comment

                  Latest Posts

                  Collapse

                  Topics Statistics Last Post
                  Started by ct, Today, 01:53 AM
                  0 responses
                  4 views
                  0 likes
                  Last Post ct
                  by ct
                   
                  Started by SmartArtsStudio, Yesterday, 11:24 PM
                  0 responses
                  3 views
                  0 likes
                  Last Post SmartArtsStudio  
                  Started by kenz987, Yesterday, 10:06 PM
                  0 responses
                  4 views
                  0 likes
                  Last Post kenz987
                  by kenz987
                   
                  Started by AaronKoRn, Yesterday, 07:24 PM
                  0 responses
                  8 views
                  0 likes
                  Last Post AaronKoRn  
                  Started by Aquatrade, 05-15-2021, 11:46 AM
                  1 response
                  17 views
                  0 likes
                  Last Post NinjaTrader_ChelseaB  
                  Working...
                  X