• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

LinReg bug

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    LinReg bug

    Entering a Period = 1 for @LinReg results in the following error:
    Indicator 'Squeeze': Error on calling 'OnCalculateMinMax' method on bar 0: The calculation results in unrenderable values.

    Period = 1 works for NT7.

    #2
    Hello traderpards,

    I am not able to reproduce this behavior using the LinReg indicator that is supplied with NinjaTrader.

    That said, the error message indicates that the Squeeze indicator is the indicator generating the error and not the LinReg. There is not a Squeeze indicator included with NinjaTrader. This would be a 3rd party custom script.

    If you start NinjaTrader without a saved workspace and add only the LinReg indicator to a new chart with a period of 1, are you able to reproduce the error?
    Please let me know if you would like directions to start NT without a saved workspace.
    Chelsea B.NinjaTrader Customer Service

    Comment


      #3
      I put this in the wrong spot so you probably thought I meant it's for NT7. I meant to put it in NT8 and yes, it does reproduce in NT8 when you put 1 in for the Period. If you put 2, it works.

      Sorry about that. This is a bug in NT8, and RSqueezeV2 will also likely generate it because it uses LinReg there.
      Last edited by traderpards; 11-23-2016, 06:10 PM.

      Comment


        #4
        Is safe mode the same thing? I restarted in safe mode, brought up chart with whatever bar type was the default - didn't notice which one - and loaded only a 1-period LinReg indicator, or tried to. Got the same error.

        Then I restarted in normal mode and after I reloaded all my strategies, which apparently get blown away in safe mode, tried to load a 10 minute chart with only a 1-period LinReg. Got the same error.

        This is all in NT8, from an indicator that I modeled after RSqueezeV2, which uses LinReg. You're right, that indicator did cause the error but I traced it down to LinReg, which chokes when period =1. Any other period works fine, just not 1, contrary to LinReg in NT7, which works just fine with period = 1.
        Last edited by traderpards; 11-23-2016, 09:55 PM.

        Comment


          #5
          Hello,

          Thank you for the reply.

          Regarding the LinReg, I do see this error and will report it, thank you for posting this. In the future please ensure to post all NT8 items in the NT8 forums to avoid confusion, I have moved this thread to the correct forum.

          Regarding Safe mode, it is not the same as the normal launch, this disables NinjaScript addons and quite a few other items, this mode is intended for testing the core platforms stability. Safe Mode will prevent NinjaTrader from:

          Loading workspaces.
          Connecting on start-up.
          Loading custom assemblies.
          Getting instrument updates from the server.

          This can help in the case you can not get the platform to open at all.


          I look forward to being of further assistance.
          JesseNinjaTrader Customer Service

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by fredfred, Today, 03:41 AM
          2 responses
          8 views
          0 likes
          Last Post fredfred  
          Started by TraderYoda, Today, 03:33 AM
          0 responses
          1 view
          0 likes
          Last Post TraderYoda  
          Started by pjsmith, Today, 02:56 AM
          0 responses
          3 views
          0 likes
          Last Post pjsmith
          by pjsmith
           
          Started by ntbone, Yesterday, 08:10 PM
          0 responses
          11 views
          0 likes
          Last Post ntbone
          by ntbone
           
          Started by chrislou, 08-28-2015, 03:27 AM
          14 responses
          2,884 views
          0 likes
          Last Post nkhoi
          by nkhoi
           
          Working...
          X