• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Trade Times are Not accurately being reported in Trade Performance Grid

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Trade Times are Not accurately being reported in Trade Performance Grid

    Times are all over the place. MAE is all wrong. I just rebuilt yesterday and replaced Database for today.

    #2
    Replacing the database file would remove all locally stored order history. My first suspicion is that some of your executions came in from your connection which would all have a time stamp of the moment that you connected. Is this what you're observing?

    Troubleshooting this further will take looking deeper into your database and other sensitive information.

    If you are experiencing something other than what I mentioned, please write in to PlatformSupport [AT] NinjaTrader [DOT] com. Please include a brief description of what you're experiencing, a link to this forum thread, and reference #1621920 ATTN Patrick G
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      Patrick
      Here is one Trade pictured on Chart with Chart time labeled.
      Look at Snapshot of Trade in Grid. Look how far off the time is off
      Then look at the MAE on this trade. It never even went a Tick against me.
      then Look at PC time. This particular trade is Sim Trade so it didn't get trade info by downloading and regardless I didn't reboot or disconnect all day.
      Attached Files
      Last edited by JerryWar; 12-13-2016, 02:19 PM.

      Comment


        #4
        I'll need to review your database to further analyze and troubleshoot what you're reporting.

        please write in to PlatformSupport [AT] NinjaTrader [DOT] com. Please include a brief description of what you're experiencing, a link to this forum thread, and reference #1621920 ATTN Patrick G
        Patrick G.NinjaTrader Customer Service

        Comment


          #5
          I have already reported a case re MAE being badly wrong... it may be you have the same issue. For me, my strategy adds a daily series, but trades off a 1 minute bar.

          I traced the problem with MAE, instead of being (for your long trade) entry price - minimum price during trade, what NT8 does is report trade entry price - minimum for the DAY!! (Or, maybe even the day following the trade, may depend on time of day/sessions etc).

          This ONLY happened to me if I add the daily series - so - question is - does your strategy/trade do the something similar - ie any daily objects in sight?

          Hope it helps ... and will be glad when NT8 fixes this!

          Comment


            #6
            I suspected something like that. I have multiple time frames on that chart. I have also reported an issue with Multiple time frames and the Trade arrows. If you add a second data series and let it plot the trade trade markers on both series. The markers will be at different times.This is different than the single trade marker with multiple series I just reported. So it is no leap for me to believe it is all related to the multiple series.

            Thanks for the info.
            Jerry

            Comment


              #7
              Thanks for the additional details, tgn55. I am currently working with the Development Team to narrow down what you and JerryWar have experienced.
              Patrick G.NinjaTrader Customer Service

              Comment


                #8
                Originally posted by JerryWar View Post
                Patrick
                Here is one Trade pictured on Chart with Chart time labeled.
                Look at Snapshot of Trade in Grid. Look how far off the time is off
                Then look at the MAE on this trade. It never even went a Tick against me.
                then Look at PC time. This particular trade is Sim Trade so it didn't get trade info by downloading and regardless I didn't reboot or disconnect all day.
                Thanks. I've been complaining about these mae mfe for quite some time. I still don't understand nt8 reporting.

                Comment


                  #9
                  I added a daily series to the SampleMACrossOver and had it execute on minute data, but I did not receive unexpected MAE.

                  tgn55 and JerryWar, ideally I would like to test with your strategies.

                  JerryWar, I will be following up via email.

                  tgn55, could you write in to PlatformSupport [AT] NinjaTrader [DOT] com and include a link to this forum thread and reference #1621920 ATTN Patrick G. Include your strategy, and specific steps to reproduce the unexpected behavior.
                  Patrick G.NinjaTrader Customer Service

                  Comment


                    #10
                    Strategy ??? No strategy just manual Entry with simple ATM profit and stop.
                    I can't get to my strategies until these issues are ironed out.

                    Comment


                      #11
                      JerryWar, please follow up with me via email so we can discuss the specific steps to reproduce what you've experienced.
                      Patrick G.NinjaTrader Customer Service

                      Comment


                        #12
                        Sledge and tgn55
                        Since your last reinstall that replaced the database. Have either of you had even one custom code execution error unrelated or otherwise ? I am starting to notice a pattern where if I am working on some code and get some random common code error ( not on compile ) on execution, example "index out of range." That is when i start to see some of these other issues. Today after some errors I tried to save a chart template and it gave me an error for no reason. I reinstalled without the database and everything is find even my chart markers and MAE are fine so far today after the Reinstall creating a new database. I am not sure it totally the database but I have found it is one thing that has to be replaced.

                        Jerry
                        Last edited by JerryWar; 12-14-2016, 10:04 AM.

                        Comment


                          #13
                          Originally posted by JerryWar View Post
                          Sledge and tgn55
                          Since your last reinstall that replaced the database. Have either of you had even one custom code execution error unrelated or otherwise ? I am starting to notice a pattern where if I am working on some code and get some random common code error ( not on compile ) on execution, example "index out of range." That is when i start to see some of these other issues.
                          No. (Not yet at least).

                          I have a couple running strategies that it can't find at start up (from previous crashes), but it looks like those are ignored/not causing issues.

                          Been running nightly market replays on over 3 years of es days without internal nt8 exceptions and getting expected results. (Other than mae/mfe confusion).

                          I'm going to explore what you and tgn55 have described and try to see if that makes sense to me.

                          Comment


                            #14
                            I have had index out of range errors at some point, so it may be related.

                            I'm going to reply to Patrick's post with more details ... I have found the weird MAE errors are dependent on the dates ... in short, if I run my strategy starting in say 2013, all is fine until about mid 2016 ... only then do I see the MAEs that clearly are referencing daily high/low values rather than the correct within-trade period minute values. Very weird... go figure.

                            I'll include test code in reply to Patrick

                            Comment


                              #15
                              Sorry... including strategy test code here for sledge, JerryWar & others

                              I run this on GC... you can toggle inclusion of the daily series, and this runs on both NT7 & NT8. The "interesting" date range starts around July. Best to start from June 1 or even earlier... you will see correct MAEs (30 ticks or whatever you set the stop to) reported... in July and onwards it goes badly wrong.

                              Set Analysis to show Trades by Ticks ... any MAE greater than the stop loss (30) is wrong.

                              Subtract the reported (bad) MAE from trade entry ... and compare to highs/lows on a daily chart (either same day or following day, it probably depends on the time of trade & session end etc).. I found they lined up to the tick.

                              So a) there's some bad stuff happening, and b) it is data (or date) dependent. My provider is CQG, FYI.

                              This has already been sent to Support back in November.
                              Attached Files

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by bchip, Today, 09:25 AM
                              1 response
                              9 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by Tomass, Today, 09:25 AM
                              2 responses
                              11 views
                              0 likes
                              Last Post Tomass
                              by Tomass
                               
                              Started by hundert, Today, 08:37 AM
                              3 responses
                              18 views
                              0 likes
                              Last Post NinjaTrader_Melissa  
                              Started by ronaldgreene828, Today, 08:16 AM
                              1 response
                              7 views
                              0 likes
                              Last Post NinjaTrader_PatrickG  
                              Started by hir04068, Today, 01:36 AM
                              1 response
                              18 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Working...
                              X