Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Can't access XAU & XAG | FXCM

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't access XAU & XAG | FXCM

    I'm not being able to access the XAU/USD and XAG/USD instruments through the NinjaTrader FXCM broker. Neither Forex or CFD. No error is shown. I can get data from other CFDs like GER30 or USOIL but they have only 6 months of data!

    I don't have these problems with Trading Station.

    Is there any fix to this?

    NT 8.0.2.0 64-bit (Standard)

    #2
    Hello Zardo,

    Thank you for your post,

    Please go to Connections > Configure. Select your FXCM connection from the lower left. In the settings to the right, is "NinjaTrader historical data server" selected?

    If so, try unselecting this option and attempt loading the pairs again. This will use the FXCM servers, which do often have more historical data. As a note, they are sometimes slower to load data than the NinjaTrader servers.

    We look forward to assisting further.
    Eric B.NinjaTrader Customer Service

    Comment


      #3
      Hi Eric,

      Thank you for the quick reply.

      I unselected the "NinjaTrader historical data server" option. After restarting the connection I got a lot of error messages, one from each instrument chart opened:

      Error on requesting bars series: 'Downloading historical data for 'USDJPY' failed: Invalid request. Instrument is not found.'
      Error on requesting bars series: 'Downloading historical data for '@GER30' failed: Invalid request. Instrument is not found.'
      Etc...

      Comment


        #4
        Thank you for your reply,

        To test, please reset your instruments, this will ensure that the internal setting for the instruments are up-to-date with server specifications: To reset your instruments please follow the steps below.


        * Disconnect from any active datafeed: Navigate to the Control Center > Connections menu, left-click the ‘disconnect’ button that appears to the right of any active connection.
        * Reset your instruments: Navigate to the Control Center > Tools > Database window, left-click to expand the ‘Update instrument lists’ section, ensure ‘Predefined instrument lists’ is checked, then left-click the Update button that appears just to the right of the two options in this section.
        * Restart NinjaTrader.



        Let me know if you see the same after taking these steps.
        Eric B.NinjaTrader Customer Service

        Comment


          #5
          Originally posted by NinjaTrader_EricB View Post
          * Disconnect from any active datafeed: Navigate to the Control Center > Connections menu, left-click the ‘disconnect’ button that appears to the right of any active connection.
          * Reset your instruments: Navigate to the Control Center > Tools > Database window, left-click to expand the ‘Update instrument lists’ section, ensure ‘Predefined instrument lists’ is checked, then left-click the Update button that appears just to the right of the two options in this section.
          * Restart NinjaTrader.
          Didn't help Eric.

          Same behavior...

          Comment


            #6
            Thank you for your reply,

            Sorry to hear this has persisted, please write into to PlatformSupport[AT]NinjaTrader[DOT]Com along with your log and trace files and a link to this forum post.

            Documents--> NinjaTrader 8--> Log--> log.20161229.xxxxx for today. (log.yyyymmdd for any other date)
            Documents--> NinjaTrader 8--> Trace--> trace.20161229.xxxxx for today. (trace.yyyymmdd for any other date).
            Eric B.NinjaTrader Customer Service

            Comment


              #7
              Email sent. Thank you for your support Eric.

              Comment


                #8
                This issue is still not yet resolved despite the release notes of V8.0.3.0 saying so:

                Issue# 10953 | Fixed | FXCM | XAUUSD and XAGUSD CFD had incorrect symbol mapping

                I've attached what my XAU/USD CFD instrument edit window looks like after making an instrument update.

                If in this window I remove the @ from the 'NinjaTrader FXCM' I can then get the last price of the instrument but not the historical data (i.e. no chart).
                Attached Files

                Comment


                  #9
                  Thank you for your reply,

                  I'll let our teams here know the mapping change has not yet taken place.

                  Regarding the data, please go to Connections > Configure. Select your FXCM connection from the lower left. In the settings to the right, is "NinjaTrader historical data server" selected?

                  If so, try unselecting this option and disconnecting and reconnecting. This will use the FXCM servers, which do often have more historical data. As a note, they are sometimes slower to load data than the NinjaTrader servers.

                  We look forward to assisting further.
                  Eric B.NinjaTrader Customer Service

                  Comment


                    #10
                    Hello,

                    I'm also having the same problem, except forex data, those work just fine.
                    Just in case, I have tried all ideas mentioned above.
                    Can you let us know when this issue will be resolved?
                    Thank you.

                    NT 8.0.3.0 64-bit

                    Comment


                      #11
                      Hello Mickey654,

                      Thank you for your post.

                      Glad to assist. The previous posts were regarding the symbol mappings needing updated for the listed instruments, so these step may not address what is happening if different instruments are being loaded.

                      First, I suggest upgrading to the current version.
                      First, get your license key from NinjaTrader under Help> License Key then exit NinjaTrader
                      Click on the link: http://ninjatrader.com/PlatformDirect
                      Enter your license key and press Submit
                      Select 'NinjaTrader 8'
                      Select 'Download'
                      Critical: Before running the installer, ensure NinjaTrader is closed.

                      If you still see the same on the new version, can you please let me know the following?

                      Who are you connected to? This is displayed in green on lower left corner of the Control Center window.


                      What instrument (and expiry if applicable) have you selected?

                      (For a chart) what interval is selected?

                      Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report?

                      We look forward to assisting further.
                      Eric B.NinjaTrader Customer Service

                      Comment


                        #12
                        So let's start from the beginning:

                        platform version number was a mess up from my part I do have the latest version 8.0.8.

                        I am also connected to the FXCM(demo) account. That is why I want to update instruments to see what I can use to trade.

                        Regarding the instruments, I have all of them(E, F, FX, I), that being said none with exception of Forex pairs works, though.
                        Meaning they are just blank, no errors in the log. And with an exception as well, XAUUSD and XAGUSD those display error window.

                        "Error on requesting bars series: Unable to request historical data for XAUUSD/XAGUSD default, no symbol map is available"

                        Changing time frame does also nothing...

                        Thank you for your assistance.

                        Comment


                          #13
                          Thank you for you reply,

                          I see, for the non-Forex instruments, you will need to connect to an additional data feed. The FXCM connection only offers Forex data.

                          The below link will show all the NinjaTrader-supported data feeds and the market they support.
                          https://ninjatrader.com/support/help...y_provider.htm

                          For futures data, you may request a demo here: http://ninjatrader.com/FreeLiveData

                          Regarding the XAUUSD/XAGUSD, please reset your instruments.

                          First, disconnect from any data providers by navigating to the Control Center > Connections menu, and left-click on “disconnect” that appears to the right when hovering your mouse over any active connection
                          Next, reset your instruments by navigating to the Control Center > Tools > Database Management
                          In the Database Management window, under the “Update instruments” section, ensure that “General properties”, "Futures expiries" and “Symbol mappings” options are checked and then click Update
                          Lastly, restart NinjaTrader for the changes to occur

                          We look forward to assisting further.
                          Eric B.NinjaTrader Customer Service

                          Comment


                            #14
                            OK, now I understand.
                            Thank you, Eric, for clarifying this for me.

                            All I need is just a provider of those data, so I'll be able to trade those instruments through FXCM.

                            Well now, resetting sadly didn't help with the instrument's issue, all of them are still displayed.
                            Is there any other way how to solve this? Going through them one by one and trying which data are available is tedious...


                            Thank you for your help.

                            Comment


                              #15
                              Thank you for your reply,

                              Sorry to hear that didn't help. Please write into to PlatformSupport[AT]NinjaTrader[DOT]Com along with your log and trace files and a link to this forum post.

                              Please follow the steps below to manually attach your log and trace files to your response so I may investigate this matter further.

                              * Open your NinjaTrader folder under Documents.
                              * Right click on the 'log' and 'trace' folders and select Send To> Compressed (zipped) Folder.
                              * Send the 2 compressed folders as attachments to this email.
                              * Once complete, you can delete these compressed folders.

                              We look forward to assisting further.
                              Eric B.NinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by georgeinharmony, Today, 12:06 AM
                              2 responses
                              13 views
                              0 likes
                              Last Post NinjaTrader_Jason  
                              Started by Prisalice, Yesterday, 07:07 AM
                              2 responses
                              16 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by Futurestrader00, Yesterday, 12:04 AM
                              1 response
                              10 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by Blairski, Yesterday, 11:26 PM
                              0 responses
                              10 views
                              0 likes
                              Last Post Blairski  
                              Started by aligator, Yesterday, 02:38 PM
                              0 responses
                              10 views
                              0 likes
                              Last Post aligator  
                              Working...
                              X