Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

8.0.4.0 *Unusual OnRender behavior*

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    8.0.4.0 *Unusual OnRender behavior*

    While testing a custom indicator I noticed some very unusual behavior with OnRender method where it's being constantly called for no reason. Attached is a copy of the @SampleCustomRender indicator to illustrate what I'm seeing. This indicator is basically and exact copy but with the addition of a single display message when OnRender is called.

    To recreate, open a new chart and an output window, then add this indicator "TestRender". What you should see is the message constantly writing to the log over and over even with no connection, scrolling, or changes to the chart.
    Attached Files

    #2
    Hello jackyd,

    I'm finding the behavior is caused by the setting of the ZOrder to a value less than 0.
    I'm inquiring with development whether this is expected.

    I appreciate your patience.
    Last edited by NinjaTrader_ChelseaB; 02-08-2017, 05:25 PM.
    Chelsea B.NinjaTrader Customer Service

    Comment


      #3
      Thanks Chelsea, good catch. I commented out the ZOrder and it seems to be ok now. Appreciate it.

      Comment

      Latest Posts

      Collapse

      Topics Statistics Last Post
      Started by kawalecld, Today, 12:21 PM
      0 responses
      2 views
      0 likes
      Last Post kawalecld  
      Started by farzibopsu, Today, 11:52 AM
      0 responses
      4 views
      0 likes
      Last Post farzibopsu  
      Started by exjayess, Today, 11:04 AM
      1 response
      9 views
      0 likes
      Last Post NinjaTrader_ShawnB  
      Started by robertlaub, Today, 11:11 AM
      1 response
      3 views
      0 likes
      Last Post NinjaTrader_ShawnB  
      Started by sdauteuil, Today, 10:28 AM
      0 responses
      6 views
      0 likes
      Last Post sdauteuil  
      Working...
      X