• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NT 8.0.4.0 Unhandled Exception - severe BUG

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    NT 8.0.4.0 Unhandled Exception - severe BUG

    Hi,
    there seems to be a serious bug in NT 8.0.4.0. -- see picture.

    It happends when maximizing chart (left price row - right click mouse - MAximizing) and then scrolling through the indicators and chart windows.

    After toggling through it is not possible to right-click into the chart at any position!

    Please correct or show how to solve.

    Thanks.
    Attached Files
    Last edited by Trader108; 02-09-2017, 04:02 AM.

    #2
    Hello Trader108,

    I cannot reproduce the unhandled exception so far. I added multiple indicators in a chart and set Scale justification to Left for the data series. I right click, select Maximize and scroll through the panels. I then set Scale justification to Left for all indicators, but I can still scroll through the panels after selecting Maximize.

    Can you please send me your log and trace files so I can investigate. Log and trace files can be found at the following locations. Right click the log and trace folder and select Send to-->Compressed (zipped) folder. Subsequently attach both .zip files in your email and send it to platformsupport[at]ninjatrader[dot]com. Put 'Att Jason, 1658337' in the subject header.

    Windows start menu-->Documents-->NinjaTrader 8-->log

    Windows start menu-->Documents-->NinjaTrader 8-->trace
    JasonNinjaTrader Customer Service

    Comment


      #3
      Hi Jason,

      see files attached.

      I am working with Windows 10 Home - actual version and I'm using the virtual Desktop frature of Win 10. By that I mean that I have spread chart windows over 3 virtual desktops.

      Try this in order to reproduce this effect::
      Open NT 8 - load an instrument - Klick on "virtual desktop" icon on the Taskbar - move a chart window to another desktop (e.g. 2) and then toggle the chart between maximize and the attached indicators.

      It is likley possible for you to reproduce this failure or display.

      If not maybe attached files are showing a cause for this.

      Looking forward receiving a solution.
      Attached Files

      Comment


        #4
        Trader 108, thank you for posting back!

        I was unable to reproduce what you're experiencing with the chart. In the log and trace files, I found the following unhandled exception.

        2017-02-09 09:57:40:605 *************** unhandled exception trapped ***************
        2017-02-09 09:57:40:605 Element already has a logical parent. It must be detached from the old parent before it is attached to a new one.
        2017-02-09 09:57:40:605 System.InvalidOperationException: Element already has a logical parent. It must be detached from the old parent before it is attached to a new one.
        at MS.Internal.Controls.InnerItemCollectionView.Asser tPristineModelChild(Object item)
        at MS.Internal.Controls.InnerItemCollectionView.Add(O bject item)
        at System.Windows.Controls.ItemCollection.Add(Object newItem)
        at NinjaTrader.NinjaScript.Indicators.Infinity.SupDemZones.contextMenuOpening(Object sender, ContextMenuEventArgs e)
        at System.Windows.RoutedEventArgs.InvokeHandler(Deleg ate handler, Object target)

        The same unhandled exception was found many times throughout the diagnostic files.

        In this error, the indicator, SupDemZones, was mentioned. If you remove the SupDemZones add-on and then troubleshoot by attempting to move the chart window to another desktop, maximizing and minimizing, do you experience the same?
        Riley S.NinjaTrader Customer Service

        Comment


          #5
          Thanks for the hint. I will test it after the session.

          Comment


            #6
            Hi,

            same Problem as before. I have removed named indicator then moved the window to desktop #1 - maximized it - toggled through - same message as before.

            Interestingly I haven't get this behaviour on the orginal loaded virtual desktop which was desktop 3 on my PC.


            See pics.
            Attached Files

            Comment


              #7
              Trader108, thanks for posting back.

              So we can further diagnose your system, please start NinjaTrader in Safe Mode.

              Safe Mode will prevent NinjaTrader from:

              Loading workspaces.
              Connecting on start-up.
              Loading custom assemblies.
              Getting instrument updates from the server.
              To enable safe mode, please use the following steps:

              Exit NinjaTrader.
              Hold the CONTROL key and double click the NinjaTrader icon.
              Keep the CONTROL key held down until you see the Control Center.
              You can verify you are in safe mode by going to Help -> About.

              After loading NinjaTrader in safe mode, please test connecting to your data provider and then opening a chart window. After this is done, please test again to see if you're able to reproduce the same error message.

              Please let me know what you find out.
              Riley S.NinjaTrader Customer Service

              Comment


                #8
                Hi Riley,
                I did what you said. Point is that all my custom indicators are not visible in NT8 safe mode.

                I have loaded a chart, put on the chart some default indicators. All worked fine. No problems with this configuration.

                ADDED:

                I have tested NT8 in normal mode. And the described bug does not come up.

                An important point might be that I am running NT7 as my trading system and I am testing the NT8 platform in parallel. So I have 2 NT systems running, NT7 and NT8. It seems that this failure appears when both systems on same PC are active and one NT8 chart windows is moving over a NT 7 chart window.
                Last edited by Trader108; 02-09-2017, 03:49 PM.

                Comment


                  #9
                  Trader 108, thanks for posting back!

                  I tested this on my end and still wasn't able to reproduce what you are experiencing.

                  When you had NinjaTrader 7 running, are you able to see the error when NinjaTrader 8 is running in safe mode?

                  If you don't experience the same, please test the following steps.
                  1. For the chart you experience the error on, please save a template by right-clicking on the chart window and select Templates > Save as > Tester
                  2. Close all open workspaces by navigating to the Control Center > Workspaces > Hovering your mouse over the open workspaces you have and select close
                  3. Next, once all workspaces are closed, by default, a new and blank workspace will open
                  4. Open a chart and apply the chart template which you may do by navigating to the Control Center > New > Chart
                  5. Next, select the instrument and towards the right-hand side apply your settings
                  6. Be sure to apply the Tester chart template by selecting the chart template in the upper right-hand corner of the data series window
                  7. Next, test the chart to see if you're able to reproduce the same error message


                  If you're able to reproduce the error message, please test removing an indicator one at a time until you don't see the error. You may do this by right-clicking on the chart window and selecting Indicators. In the indicators window, right-click an indicator, select remove, and click OK. After clicking OK, please test to see if you able to see the same error message.
                  Riley S.NinjaTrader Customer Service

                  Comment


                    #10
                    Hi Riley, I'll go through your suggestions as soon as I can. Thanks.

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by vivekniwas, Today, 04:56 PM
                    0 responses
                    3 views
                    0 likes
                    Last Post vivekniwas  
                    Started by dtl-saw, Today, 03:36 PM
                    1 response
                    10 views
                    0 likes
                    Last Post NinjaTrader_ChrisL  
                    Started by williamzz, Today, 02:04 PM
                    2 responses
                    11 views
                    0 likes
                    Last Post williamzz  
                    Started by jtrading82, Today, 01:55 PM
                    3 responses
                    27 views
                    0 likes
                    Last Post NinjaTrader_Tyler  
                    Started by StevenNelson, Today, 01:00 PM
                    4 responses
                    19 views
                    0 likes
                    Last Post StevenNelson  
                    Working...
                    X