• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Some Indicators not Working on NT Version 8.0.5.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • aligator
    replied
    Originally posted by NinjaTrader_ChelseaB View Post
    Are you unable to reproduce the error with 8.0.4.0?
    I was able to reproduced the error in NT8.0.4. In the process cleaned the Ninja Cache folder, and that fixed the issue. No more issue with NT8.5 after re-install.

    Funny how the cache folder can get corrupted and causes issues.

    Thanks.

    Leave a comment:


  • NinjaTrader_ChelseaB
    replied
    Hello aligator,

    Below is a link to the release notes for 8.0.5.0.
    http://ninjatrader.com/support/helpG...us/8_0_5_0.htm

    There were changes on AddDataSeries() and OnStateChange() from 8.0.3.1 to 8.0.4.0, but I'm not aware of any changes like these in 8.0.5.0.

    Are you unable to reproduce the error with 8.0.4.0?

    Re-install means uninstall from the Windows Control Panel -> Programs and Features and then install again by running the installer. This does not require deleting your settings folder.

    Leave a comment:


  • aligator
    started a topic Some Indicators not Working on NT Version 8.0.5.0

    Some Indicators not Working on NT Version 8.0.5.0

    Dear Support,

    I just upgraded to NT 8.5 and some indicators that were perfectly working on NT8.4 will stop running on NT8.5 with the following error in all 3 Output Window, Log file, and Trace file:

    " Indicator ' ': Error on calling 'OnBarUpdate' method on bar 8: You are accessing an index with a value that is invalid since it is out-of-range. I.E. accessing a series [barsAgo] with a value of 5 when there are only 4 bars on the chart."

    I decided to downgrade back to NT8.4 but now I am asked to Uninstall the newer version first.

    Two Questions:

    1. Why the upgrade from Version 4 to 5 causes indicators not work? Any specific areas of the indicators are affected by NT5 changes that need to re-coded?

    2. What is meant by re-install? Do I need to do a complete and clean reinstall? Or should I keep my custom material under Documents>NinjaTrader8 folder? I certainly do not want to loose these custom stuffs.

    Thank you.

Latest Posts

Collapse

Topics Statistics Last Post
Started by Stevetrader, Yesterday, 03:46 AM
1 response
5 views
0 likes
Last Post NinjaTrader_Marco  
Started by arewents, Today, 05:02 AM
0 responses
1 view
0 likes
Last Post arewents  
Started by NeuTronite, 01-25-2020, 08:40 PM
1 response
7 views
0 likes
Last Post NinjaTrader_Marco  
Started by rtwave, Today, 04:40 AM
0 responses
2 views
0 likes
Last Post rtwave
by rtwave
 
Started by pollard89143, Today, 04:21 AM
0 responses
6 views
0 likes
Last Post pollard89143  
Working...
X