Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Historical Data Playback and Switching Instruments using Market Analyzer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Historical Data Playback and Switching Instruments using Market Analyzer

    Please see attached screenshot.

    When using the Playback feature, all the data plays back fine for the currently selected instrument.

    However when switching to another instrument, there are gaps in the data for the period where the instrument was not selected in Market Analyser.

    Is there any way to have all charts update without gaps with playback data, or refresh with historical data filled in up to the current time (as per the playback tool) when the instrument is selected?
    Attached Files

    #2
    rs123456, thanks for posting!

    I tested this on my end and was able to view the historical data for the playback connection and was able to view the historical data I had. If switching instruments, you will have to ensure that you have the historical minute and tick data downloaded for your 1440 minute chart and for each instrument you would like to playback. Now, this is different for the license key type you have. For example, if you have a simulation key, you will require a live data provider to download the minute data for your forex instruments and if you have a live license key, minute data will be provided to you for most futures and forex types of instruments.

    To download more historical minute data, please take the steps below.
    1. Disconnect by navigating to the Control Center > Connection > disconnect
    2. Connect to a live data provider: Connection menu of the Control Center
    3. Navigate to the Control Center > Tools > Historica Data
    4. Navigate to the Load tab
    5. In the Historical Data window, expand the Download section by clicking the left facing arrow
    6. In the Instrument pull down menu, select instrument(s) you would like to see more minute data of
    7. For Intervals, ensure you check the Minute box
    8. For the Start Date and End Date fields, include a date range of the data you would like to see
    9. Click Download


    You will see at the bottom right corner of the Historical Data window the data downloading, and once it's completed, connect to the Playback Connection. You should see more historical data for your 1440 minute chart.

    Please let us know if you continue to see the same.
    Riley S.NinjaTrader Customer Service

    Comment


      #3
      Hi Riley,

      Sorry, forgot to mention that the gaps are most apparent in the 60min and 15 min charts.

      In the screenshot as an example I had played back EURJPY data, then switched to EURUSD, then switched back. The gaps in the 15 mins and 60 min chart being for the playback time I had switched to EURUSD.

      Is there any way to fill these gaps with the data once I switch back from another instrument? Or is it possible to have it print on the chart in the background?

      Comment


        #4
        rs123456, thank you for posting back.

        I'm not able to reproduce the same gaps as you. Please answer the following questions so that I may investigate this further.

        What version of NinjaTrader are you using? You can check under Help -> About (Example: 7.0.1000.X or 8.0.X.0)

        Do you have a live data provider you connect to? If so, what data provider?

        Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report?

        I look forward to being of further assistance.
        Riley S.NinjaTrader Customer Service

        Comment


          #5
          What version of NinjaTrader are you using? You can check under Help -> About (Example: 7.0.1000.X or 8.0.X.0)


          8.0.5.2 64-bit (Multi-Broker)


          Do you have a live data provider you connect to? If so, what data provider?

          No, I'm using imported data. The only connection is to the "Playback Connection"


          Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report?

          No errors.

          Comment


            #6
            rs123456, thank you for posting back.

            Unfortunately, I am unable to test this on my end because I don't have access to the customly imported data. If you would like me to test this further, I would also have to test the data that you're using. If you would like to send me the data so that I may investigate this further, please attach the files to an email and send to platformsupport[at]ninjatrader{at]com. In the body in the email, please be sure to type ATTN: Riley and to include this link: http://ninjatrader.com/support/forum...ad.php?t=98714

            I look forward to being of further assistance.
            Riley S.NinjaTrader Customer Service

            Comment


              #7
              Please download the tick data files using the below link:

              https://mega.nz/#F!acITXSRL!YibErS3p6wcmpNIaI4D89Q

              Comment


                #8
                rs123456, thank you for posting back.

                I was able to reproduce when importing as tick data only, however, when generating minute bars when importing, I didn't experience the same. I would advise that you re-import the data generating minute bars. To do so, disconnect from your data provider (Connections > disconnect). Next, navigate to the Control Center > Tools > Import > Historical Data. Next, ensure that you check the option, "Generate 'Minute' bars from imported tick data." Lastly, click Import and select the data files that you provided me.

                Please let me know if you continue to experience the same or if you have already done this.
                Riley S.NinjaTrader Customer Service

                Comment


                  #9
                  I had already selected to generate minute bars.

                  I've deleted all the historical data and followed your steps to import the data again.

                  Unfortunately I'm still seeing gaps when switching back and forth between instruments using the market analyser.

                  Comment


                    #10
                    rs123456,

                    I tested this further on my end and still can't reproduce the same, unfortunately. When I had attempted in troubleshooting this, I had a fresh workspace. If you recreate your workspace, close out any open and running workspaces, and then restart, do you see the same?

                    In the Workspaces pull down menu of the Control Center, the workspace name with any boxes to the left of the name indicates that the workspace is open--the one workspace with a green box on top of the grey box indicates it's the workspace you're currently viewing--the workspace with the grey box on top of the green box indicates that the workspace(s) is open and running in the background. If you click close, then the workspace will close. After closing the workspace, you will no longer see boxes to the left of the workspace name which indicates it's not running in the background. If you close the current workspace you're viewing, a new blank workspace will open by default.

                    I look forward to being of further assistance.
                    Riley S.NinjaTrader Customer Service

                    Comment


                      #11
                      Thanks for your help. I followed the steps and created a new workspace.
                      Adding a single chart allowed me to switch instruments without causing gaps in the chart data. However after adding additional charts, the gaps started appearing again.

                      I have now solved the issue by simply having all the charts I need open at the same time and switching between instruments using an AHK script.

                      Comment

                      Latest Posts

                      Collapse

                      Topics Statistics Last Post
                      Started by MidenThur, Today, 12:52 AM
                      0 responses
                      3 views
                      0 likes
                      Last Post MidenThur  
                      Started by seseoraf, Today, 12:51 AM
                      1 response
                      4 views
                      0 likes
                      Last Post charmingishagarg  
                      Started by Rosario, Today, 12:50 AM
                      0 responses
                      2 views
                      0 likes
                      Last Post Rosario
                      by Rosario
                       
                      Started by kemoyums, Today, 12:38 AM
                      0 responses
                      2 views
                      0 likes
                      Last Post kemoyums  
                      Started by MartynBashi, Yesterday, 11:01 PM
                      0 responses
                      4 views
                      0 likes
                      Last Post MartynBashi  
                      Working...
                      X