• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Trading Hours error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trading Hours error

    Hi, I’m having an issue with the “FOREX” trading hours template and the bars shown on my chart. (I also get the same problem when I create my own template in an attempt to replicate the correct hours).

    My forex data is the standard Sunday through Friday data so I would expect to see on my chart the following trading days. (5 bars per week). Data as been uploaded with the NT8 standard "End of Bar" time-stamps.

    Timezone: UTC - 5
    Sunday 5pm – Monday 5pm
    Monday 5pm – Tuesday 5pm
    Tuesday 5pm – Wednesday 5pm
    Wednesday 5pm – Thursday 5pm
    Thursday 5pm – Friday 5pm

    However what I see on my chart (attached) is that Sunday’s data is being shown as its own bar and not being incorporated into Monday’s bar. Additionally, this Sunday bar is being time-stamped as the previous Friday.

    For example the chart attached shows two Fri 7th Nov bars - one with the correct Friday 7th OHLC, and then a second “Friday 7th“ bar using Sunday’s OHLC data..

    Has anyone had this very frustrating problem before? Any ideas on a fix?

    Thanks very much.
    Attached Files

    #2
    Hello ehope,

    When you mention "Data as been uploaded with the NT8 standard "End of Bar" time-stamps" where did this data come from?

    Is this minute data or daily data?

    Daily bars come fully formed from the provider and the trading hours template cannot be applied.

    What instrument are you loading on your chart?

    What version of NinjaTrader are you using? (Help -> About... e.g. 8.X.X.X)

    Attached is a screenshot of an $EURUSD daily chart with the data coming from a connection to an FXCM demo account.
    Attached Files
    Chelsea B.NinjaTrader Customer Service

    Comment


      #3
      Hi Chelsea, the data I'm using is EURUSD from Histdata.com. It is time-stamped at UTC-5 and is minute data not daily.

      http://www.histdata.com/download-fre...-quotes/EURUSD

      Current NT version is 8.0.6.1.

      Thanks very much.

      Comment


        #4
        Hello ehope,

        Thank you for your response.

        The imported data is creating a Sunday bar on my end as well. This is due to the fact that the data ends on Sunday as there is no Monday data in the file for today. However, I do not see a bar for the 7th as the data is appropriately creating only the bar on the 8th.

        So there could be two reasons for this on your end;
        • It could be that the data in your database is from a prior import that did not include the Monday. I would recommend clearing your Historical data for the month of May by going to Documents\NinjaTrader 8\db\Minute\EURUSD and deleting the dates for the Month of May > then download and import the data again from the website.
        • It could be the cache has the incorrect session stored. Please shut down NinjaTrader > go to Documents\NinjaTrader 8\db on your PC > delete the cache folder > restart NinjaTrader.

        Please let me know if neither of the items above resolve this matter.
        Patrick H.NinjaTrader Customer Service

        Comment


          #5
          Hi Patrick, sorry I forgot to provide the year and month of the example given. The example chart above was January 2011, not May 2017. Do you still get the same issues I do when using Histdata for Jan11?

          I have deleted downloaded data many times but have not tried deleting the cache files.

          Thanks vm.

          Comment


            #6
            Hello ehope,

            Thank you for your response.

            I am able to reproduce this with the data from your source as well as from other providers on my end.

            I will report this item to development.
            Patrick H.NinjaTrader Customer Service

            Comment


              #7
              I'm experiencing a similar issue with Trading Hours and Forex data.
              I've created 4 trading hours templates according to London (2 to 11h), New York (7 to 16h), Tokio (19 to 4h) and Sydney (16 to 1h). Trading hours in UTC-6.
              When I open a new chart with London and NY templates, chart is OK, but if I open a chart with Tokio or Sydney templates, it opens and closes 1h before. Tokio opens template at 18h and closes at 3AM, and Sydney template opens at 15h at closes at 00h. This only appears when open and close hours are from one day to the next.

              Comment


                #8
                Hello esborsa,

                Thank you for your post.

                Can you provide screenshots of the Session Templates you are using?

                To send a screenshot with Windows 7 or newer I would recommend using Window's Snipping Tool.

                Click here for instructions: http://windows.microsoft.com/en-us/w...#1TC=windows-8

                Alternatively to send a screenshot press Alt + PRINT SCREEN to take a screenshot of the selected window. Then go to Start--> Accessories--> Paint, and press CTRL + V to paste the image. Lastly, save as a jpeg file and send the file as an attachment.

                Click here for detailed instruction: http://take-a-screenshot.org/

                I look forward to your response.
                Patrick H.NinjaTrader Customer Service

                Comment


                  #9
                  Hello Patrick,
                  Here are screenshots of trading hours template for Tokio session (Forex3) and Sydney session (Forex4)
                  Attached Files

                  Comment


                    #10
                    Thank you, esborsa.

                    I am able to recreate the exact same scenario you detailed. I will report this to development.
                    Patrick H.NinjaTrader Customer Service

                    Comment


                      #11
                      Thanks Patrick. This also affects to strategy analyzer

                      Comment


                        #12
                        Hello esbora,

                        Thank you for your response.

                        I was incorrectly verifying this on 60 minute cars and looking at the timestamp which is the time the bar closed. Can you provide a screenshot of the chart you are testing the Trading Hours templates on?

                        I look forward to your response.
                        Patrick H.NinjaTrader Customer Service

                        Comment


                          #13
                          Hello Patrick,
                          Here are screenshots of 5 min AUDCAD charts for Tokio session (Forex3) and Sydney session (Forex4. Pointer is located at 1st bar, so you can see its closing time (18.05 instead of 19.05 for Tokio and 15.05 instead of 16.05 for Sydney template).
                          Attached Files

                          Comment


                            #14
                            Hello esborsa,

                            Thank you for your response.

                            I would like to schedule a call with you to look into this further on your PC. Please send me a note to platformsupport[at]ninjatrader[dot]com with your telephone number and a time window when I may reach you.
                            Please list 'ATTN: Patrick H' in the subject line and reference this thread in the body of the email.

                            I look forward to your response.
                            Patrick H.NinjaTrader Customer Service

                            Comment


                              #15
                              Hello Patrick,
                              I'm experiencing issues again with trading hours templates and strategy analyzer.
                              SA correctly backtests strategy with a concrete trading hour template but if I close NT and execute again, when trying to recover saved backtest, it presents it without trading hour template.
                              I've made a video showing this
                              https://www.4shared.com/video/ZVUOAWa_ca/SA_online.html

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by GATT1, Yesterday, 03:56 PM
                              2 responses
                              18 views
                              0 likes
                              Last Post GATT1
                              by GATT1
                               
                              Started by rickyblah12, Today, 03:07 PM
                              5 responses
                              15 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Started by itrader46, 10-03-2019, 06:18 AM
                              35 responses
                              190 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by aslane, Today, 03:09 PM
                              1 response
                              12 views
                              0 likes
                              Last Post rickyblah12  
                              Started by stoner, Today, 02:36 PM
                              1 response
                              5 views
                              0 likes
                              Last Post NinjaTrader_Melissa  
                              Working...
                              X