• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Visual Sudio or Cummunity

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Visual Sudio or Cummunity

    I am confused. Which version of C# is supported by NT? What components of the download do I need to hook into the NinjaScript Editor? Would anyone have a link to the correct site? I just purchased a new computer that will be dedicated for NT8 so I really don't want to be installing software that is not needed for NT8 and the MS website confuses the crap out of me.
    Any help would be greatly appreciated. Thanks

    #2
    Hello TAJTrades,

    NinjaTrader 8 is written in .NET 4.5.

    No configuration the NinjaScript Editor is necessary.

    Install NinjaTrader, then open a new NinjaScript Editor by clicking New -> NinjaScript Editor.

    Below is a link to some information to help you get started making NinjaScripts.
    http://ninjatrader.com/support/forum...187#post497187

    While using Visual Studio is not officially supported by NinjaTrader, we are attempting to make this easier to use to modify scripts. On the Toolbar of the NinjaScript Editor is a button for Visual Studio that is able to open the NinjaScript project in Visual Studio 2012 or 2015.
    Chelsea B.NinjaTrader Customer Service

    Comment


      #3
      Sorry Chelsea, I may not have been clear on the question. What version of Visual Studio is needed to open a NinjaScript project in Visual Studio. I have read some post about 2015 and then 2017 with some modifications. Which one should I install? Are there any components on the Visual Studio install that must be included, should be included, or absolutely not included? Looking for a little guidance here to get it correct the first time.

      Thanks

      Comment


        #4
        Hello TAJTrades,

        The NinjaTrader project can be opened in Visual Studio 2017, 2015, and 2012 directly.

        The Visual Studio button on the NinjaScript Editor will only open Visual Studio 2015 and 2012.

        I am not aware of any components needed to download in Visual Studio.
        Chelsea B.NinjaTrader Customer Service

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by RedDuke, Today, 11:40 AM
        1 response
        5 views
        0 likes
        Last Post NinjaTrader_PatrickG  
        Started by snbence, Today, 11:19 AM
        2 responses
        7 views
        0 likes
        Last Post snbence
        by snbence
         
        Started by marwanco, Today, 10:54 AM
        1 response
        5 views
        0 likes
        Last Post NinjaTrader_ChrisL  
        Started by daqu40, Today, 11:01 AM
        1 response
        1 view
        0 likes
        Last Post NinjaTrader_Kate  
        Started by n8dogg59, Today, 09:55 AM
        4 responses
        7 views
        0 likes
        Last Post n8dogg59  
        Working...
        X