• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Optimizer not displaying boolean results

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Optimizer not displaying boolean results

    Hi there,

    I've reported this issue before, but it is still unresolved in the last couple of releases and I would like to inquire about the status:

    The issue is, that after the Optimization is complete, the strategy analyzer shows the optimized results in the parameter selection area for all optimized types, but not booleans.

    The only way to get the result of boolean optimized params is to look in the "Parameters" column which looks like this for me:

    False/True/False/False/False/1/True/False/False/False/False/False/False/False/False/False/False/2/False/False/False/False/False/True/False/False/False/True/False/True/False/True/False/False/True/True/False

    Is this going to be fixed at any point. Displaying the string value of a boolean is as simple as calling _myBooleanValue.ToString() - why does the strategy analyzer do this for Enums but not booleans?


    Attached Files

    #2
    Hello kevinenergy,

    Thanks for your post.

    We had addressed some issues with optimizing bools in Release 14 with the ticket ID number 10344, but it does not look like this particular property grid issue was brought up. I have opened a new internal ticket asking about this inconsistency and I will let you know our findings.

    I look forward to being of further assistance.
    JimNinjaTrader Customer Service

    Comment


      #3
      Thanks, Jim. Would you mind also bringing to their attention, the inconsistency between how the Strategy Analyzer and the Multi-Objective Analyzer displays results? I've attached screenshots to show what I mean. If you hover on the multi objective analyzer results you get a neat list of parameter names and their optimized results that is easy to read. The strategy analyzer provides a huge one-liner list that is absolutely impossible to read.

      e.g.

      "/1/10/False/False/False/False/False/2/100/False/False/False/False/False/4/20/False/True/False/False/False/1/True/False/False/False/False/False/False/False/False/False/False/2/False/False/False/False/False/True/False/False/False/True/False/True"

      With all the amazing technical innovation in the Optimizer its a shame it falls flat like this on its data output. Surely your developers can use the same code as for the Multi-objective results to give an easy-to-read output on the strategy analyzer.

      Thanks again for raising the boolean issue.
      Attached Files

      Comment


        #4
        Happy to help, kevinenergy.

        As these grids are different from the Multi Objective chart, the mouseover behavior would reasonably be different. I understand your pain point though, so I created a feature request to note this for improvement in a future version of NinjaTrader and have also notified the Product Management team to consider putting something in their future scopes. The ticket ID SFT-3704.

        I'll keep you informed as the first item you mentioned develops.
        Last edited by NinjaTrader_Jim; 12-20-2018, 07:38 AM.
        JimNinjaTrader Customer Service

        Comment


          #5
          One more bit of feedback....

          If you run an Optimization with no parameters set to Optimize you get an error "You must have at least one parameter to Optimize".

          I think it would be better if it gave you a warning "There are no parameters set to optimize, are you sure you want to continue?"

          The reason being: before every optimization run, I want to make sure that my current "Optimal" baseline settings are in place and correct. I know that my previous optimization had net profit of $3000 and profit factor 2.5. So after I've tweaked some code and committed those opimized settings to "SetDefaults" and I'm getting ready to Optimize another aspect of my strategy. I want to make sure that my current optimal settings are in place and everything is set up to the same baseline. Therefore I would like to do run an optimization without any parameters to optimize, in order to check that my baseline settings are correct: Basically I want to confirm that I'm getting "$3000 / 2.5" (my current optimal results) before I even start a new optimization as it is from this point I want to improve/optimize.

          I can't tell you how many times I've started a 5 hour optimization, only to realise that the timeframe was wrong, my date range was wrong, or past optimal parameters were not in place. Making the whole thing invalid. In order to be truly methodical about optimization it is important to know where you're starting from which is why doing a run without any parameters set is valuable.

          I hope that's useful insight and I'm not being annoying

          Comment


            #6
            Thanks for the feedback.

            I'll be happy to open another request, but is this something that could be changed with your workflow to save a Strategy Template after you run your optimization? The best parameters should be selected automatically so you should just be able to save the template after running the optimization.

            Let me know and I'll be happy to put in another feature/enhancement request.
            JimNinjaTrader Customer Service

            Comment


              #7
              Hey Jim, no worries, I figured out I can just add a dummy boolean to force an optimization - easy peasy.

              Have a great Christmas! and thanks for all the support!

              Comment


                #8
                Thanks Kevin,

                To conclude with the first inconsistency you brought up, it has caught eyes to possibly address in the future but as it would involve substantial changes, we are currently tracking impact under the ticket ID SFT-3706.

                Thanks again for bringing this to our attention and providing your feedback.

                Have a great holiday as well!
                JimNinjaTrader Customer Service

                Comment


                  #9
                  Hey Jim,

                  Happy New Year!!

                  I've spotted another issue with the Optimizer. If you open a past multi-objective optimization from the "Show Log" table. The Settings tab is table blank, so all the Enum and Boolean optimized settings are lost.

                  Comment


                    #10
                    Hello Kevin,

                    Happy New Year!

                    When I take steps to backtest a strategy with Enums and bools in a Multi Objective Optimization, the optimized settings are not saved in the property grid which we reviewed previously, but I still see the previous settings used to run the optimization when I open an older optimization from the log.

                    Is there a different behavior that you are seeing and if so could you give me some steps I can take to reproduce on my end so I am doing the same?

                    I'll be happy to look into this further as needed.
                    JimNinjaTrader Customer Service

                    Comment


                      #11
                      Hey Jim

                      If I open a past optimization from the log, I can see the numerical optimized values in the property grid in brackets, but not the values for Enums or bools.

                      Comment


                        #12
                        Actually if I stretch the Optimizer Window the full width of both my 4K monitors the Enum result is there at the end. . Thank god because that Optimization took more than a day. Its hard to believe with all the technical innovation in this product that we need to resort to things like this to get the results out of the damn thing. Painful.

                        Unfortunately I'm back to square one on booleans though. They are gone. The properties grid only shows "Optimize" with no value there.



                        Comment


                          #13
                          Thanks Kevin,

                          The issue with bools not displaying which is inconsistent with other properties is being tracked with SFT-3706. I'm still curious about the Settings grid showing as blank, however. We can expect the grid to be greyed out or blank if a report is generating, but I would not expect a blank grid elsewhere. Is the issue presented in post #9 separate from the inconsistency that we were discussing in this thread?

                          If there are specific details with your strategy in a screenshot that you do not want to post on the forums, you can reach me at platformsupport [at] ninjatrader [dot] com. Please include the text "Attn Jim" and the ticket ID "2034953" so I can quickly grab the ticket from our main queue.

                          I look forward to being of further assistance.
                          JimNinjaTrader Customer Service

                          Comment


                            #14
                            Hey Jim, yeah this is a new problem. Are you saying you're able to see the settings in the property grid if you load a past optimization from the log?

                            Comment


                              #15
                              Hey Jim

                              I'm able to get around the missing data problem for now by right-clicking on the log entry, and choosing "Open in New Strategy Analyzer". This opens up a new window with the results shown correctly. Although it does have the added weirdness: it makes a Duplicate log entry. The duplicate entry is a "Standard" backtest type rather than a "multi-objective optimization" backtest type, which is probably why it is able to open.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by Arkadiy_B, Today, 06:43 AM
                              0 responses
                              2 views
                              0 likes
                              Last Post Arkadiy_B  
                              Started by leontancfa, Today, 06:09 AM
                              1 response
                              9 views
                              0 likes
                              Last Post NinjaTrader_PatrickG  
                              Started by soulfx, 12-01-2017, 08:44 AM
                              3 responses
                              1,019 views
                              0 likes
                              Last Post NinjaTrader_EricB  
                              Started by Parmenides48, 04-09-2019, 03:32 AM
                              10 responses
                              53 views
                              0 likes
                              Last Post NinjaTrader_PatrickG  
                              Started by NinjaCustomer, Today, 01:48 AM
                              1 response
                              13 views
                              0 likes
                              Last Post NinjaTrader_EricB  
                              Working...
                              X