• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Swing values producing 'na' result

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Swing values producing 'na' result

    I've noticed that the swing indicator produces 'na' or zero value when there is nothing to plot. This is throwing off my exits which depend on an accurate cross above the swingHigh. I understand that the Swing has these periods where there is nothing to paint to the plot when the swing condition hasn't developed yet. The problem is that my exit is using the zero (na) value as a legitimate value to trigger the exit.

    Any thoughts on how to convert the zero (na) value to another higher value during these periods before the true swing values are produced?


    #2
    Hello ShruggedAtlas,
    Thanks for your post.

    Perhaps you could check to see if the swing value is null or zero and then set it to another value instead? Have you tried that yet?
    Last edited by NinjaTrader_JoshG; 02-28-2019, 10:00 AM.
    JoshNinjaTrader Customer Service

    Comment


      #3
      yes I am experimenting with this:

      temp = (SwingADX.SwingHigh[0] == null)? 100:SwingADX.SwingHigh[0];

      Then using this as the exit:

      if (Position.MarketPosition == MarketPosition.Long
      && Position.Quantity == PositionSize
      //&& BreakEven != true
      && ADX3[0] > temp)
      {
      ExitLong(@"RESET", @"LE1");
      Print(string.Format("{0}; {1}; {2}", Time[0], ADX3[0], temp));
      }

      but unfortunately I get the same result



      Comment


        #4
        here is an image of the adx and swing(adx) plot and the bad exits

        Comment


          #5
          Update: Ok it looks like Swing(ADX) is not producing a null value even though it shows 'na' in the Data Box. Printing to Output yields what looks like the prior swinghigh from several days back. I haven't a clue how to resolve this.

          The image shows time; ADX; temp;

          since temp is never null but rather is the prior ADX value my code won't ever convert the swing value to what I want
          Last edited by ShruggedAtlas; 02-28-2019, 05:44 AM.

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by afoschini, Today, 02:57 AM
          0 responses
          1 view
          0 likes
          Last Post afoschini  
          Started by jecoyeko, Today, 12:45 AM
          0 responses
          6 views
          0 likes
          Last Post jecoyeko  
          Started by Newtrader101, Yesterday, 06:31 PM
          1 response
          9 views
          0 likes
          Last Post NinjaTrader_EricB  
          Started by Tyler7498, Yesterday, 07:34 PM
          0 responses
          4 views
          0 likes
          Last Post Tyler7498  
          Started by Woomera, Yesterday, 07:24 PM
          2 responses
          10 views
          0 likes
          Last Post Woomera
          by Woomera
           
          Working...
          X