• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

On history works, but in reality no ! What could be the problem ?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    On history works, but in reality no ! What could be the problem ?

    Why do I run the strategy and it does not work today, but the history of transactions reflects from the previous day ? What am I doing wrong and what could be my mistake ? In Strategy Analyzer everything works and in real life is not present ?

    #2
    Hello marakano,

    Thanks for your post and welcome to the NinjaTrader forums!

    Are you "Enabling" the strategy when you apply it to the chart?

    If you are enabling the strategy, please check the strategy color code in the strategy tab. Is the strategy name shown in Green or yellow/Orange, or Black/white?
    Reference: https://ninjatrader.com/support/help...tegies_tab.htm

    Paul H.NinjaTrader Customer Service

    Comment


      #3
      Strategy was Enable, and mark green color.

      Comment


        #4
        Hello marakano,

        Thanks for your reply.

        Does the strategy tab show any information regarding Position or Acct position, unrealized or Realized?

        Please check the control center's log tab for any error messages.

        Is the strategy applied to a live account or the sim101 account?

        Paul H.NinjaTrader Customer Service

        Comment


          #5
          During the trading session, there were signals on which the strategy should work, but it is silent. What is strange, but on the same signals it shows the transaction on the history since yesterday. I have written a filter according to time and days of the week. I don't know what's wrong.

          Comment


            #6
            Hello marakano,

            Thanks for your reply.

            I can see the strategy is enabled and is green indicating it is ready to place trades but has not placed trades.

            I would suggest that you debug your strategy perhaps starting with the time filter.

            Here is a link to our debugging tips: https://ninjatrader.com/support/help...script_cod.htm
            Paul H.NinjaTrader Customer Service

            Comment


              #7
              Thanks, I figured out what the problem was !

              Comment

              Latest Posts

              Collapse

              Topics Statistics Last Post
              Started by hir04068, Today, 09:29 PM
              0 responses
              1 view
              0 likes
              Last Post hir04068  
              Started by iq200, 03-11-2018, 07:49 PM
              24 responses
              1,005 views
              0 likes
              Last Post mrlucky1x  
              Started by DavidHP, Today, 08:18 PM
              0 responses
              1 view
              0 likes
              Last Post DavidHP
              by DavidHP
               
              Started by liquid150, Today, 06:20 AM
              1 response
              10 views
              0 likes
              Last Post User1104  
              Started by liquid150, Today, 06:22 AM
              1 response
              17 views
              0 likes
              Last Post lexusfood  
              Working...
              X