Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

A note for the people who manage NinajTrader development

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Harry
    replied
    Crash again

    Did only have to wait for the next day. This morning after connection to IB, after loading ES to the charts, the famous "Saving" - popup showed and would not go away (this was a brand new installation of NT). Instruments on the MA would not be loaded. Would have to abort and then play the usual tricks as described below.

    Peculiar: While connected the ES data would show correctly on the intraday charts. After shutting down and restarting NT the part of the ES data between 11:30 PM last day and the moment when the backfill was executed will not show on the charts, but leaving a hole (see attachment). The second time, I connected NT to IB, backfill was fast and easy. But the chart problem with ES remained (only when being offline). So NT has once more destroyed its database.

    Not traffic related: At the moment of backfill (7:30 Central European Time or 1:30 Eastern Time) all markets were quiet and IB backfill fast and without problems. This means that the problem is not related to heavy traffic.

    @Josh : I will send you tracefile (logfile does not contain any information) and workspace. Please let me know, if you need further data.

    Originally posted by Harry View Post
    Currently my NT installation works alright. I could not reproduce the problem either myself. I will try again and look what else it needs to cause the freeze and then come back to you.
    Attached Files

    Leave a comment:


  • Harry
    replied
    Currently my NT installation works alright. I could not reproduce the problem either myself. I will try again and look what else it needs to cause the freeze and then come back to you.

    Leave a comment:


  • NinjaTrader_JoshP
    replied
    Please also send in your workspace. Thank you Harry.

    I have tried your instructions with the database you sent in so far, but could not reproduce.

    Leave a comment:


  • NinjaTrader_Dierk
    replied
    No problem. Take your time. The more likely it's reproducible the more likely we would able to track down this issue.

    Leave a comment:


  • Harry
    replied
    Thanks for your reply.

    Thank you for your reply. Will send you DB, but first clean it up and rebuild it to make it easier to handle. May take a couple of days ... as I am not in front of my screen all day long.

    Leave a comment:


  • NinjaTrader_Dierk
    replied
    Please send your workspace and your zipped DB to "support AT ninjatrader DOT com", subject "for Dierk" and refer to this thread. Thanks

    Leave a comment:


  • Harry
    replied
    Unfortunately, the problem is not reproducible. If the problem occurs, I have to shut down NT, remove NinjaTrader.exe from the task manager and retry again. Most of the time my second try starting NT and connecting will be successful. Sometimes I have to restore the last backup, and on rare occasions I have to reinstall NT to make it work.

    I only can describe what is happening (sorry for the detail, but it might help to solve the problem):

    (1) Starting NT, workspace opens. Workspaces contains CC, 3 intraday charts connected to DOM, 1 daily chart, 1 intraday chart for TICK, 1 market analyzer with 20 instruments. The three intraday charts have different lookback periods between 65 and 120 days. There is no second or hidden workspace.

    (2a) Connecting to IB. If everything goes well, charts and instruments of the market analyzer will update within 1 or 2 minutes. The "Loading" popup can only be seen, if I put the market analyzer on top of my desktop. While the popup reads "Loading..." in the upper left corner of the popup, all the instruments will be called one by one (instrument and last date displayed by popup). During this process the popup will alternately display the instrument loaded (including last date) and the information "Saving".

    (2b) Sometimes this process gets stuck after loading the instrument displayed on the chart. The Saving popup will show forever without any processor load (nothing happens). Aborting is not possible, but will simply convert the "Saving" popup to an "Aborting. Please wait.." popup, which will also remain forever. The charts just display some horizontal lines, separating the indicator panes, but no data.

    If I shut down NT in ths stage, the data base is likely to be destroyed. I found a way out of this by pretending to close NT, but then selecting "Cancel". This will remove the "Aborting" popup. Now NT will try to continue to load data for the remaining instruments of the market analyzer. This time the instruments will be displayed each without the date, and the "Saving" popup that comes after each instrument can be manually aborted. So I will click "Abort" a 15 or 20 times until all instruments of the market analyzer have had their turn. Now I will shut down the connection and close NT.

    Now the desktop of my PC is empty, and you might think that NT has been shut down. Not so. It is still running in the background, so it cannot be restarted. To solve this, I have to use the Task Manager and remove NinjaTrader.exe from the running processes. Having achieved this, I can restart NT.

    (3) After restarting NT and connecting again, usually it will load data without any problems. If it does not, I may restore yesterday's backup, and it is likely that everything works afterwards.




    Originally posted by NinjaTrader_Dierk View Post
    @Harry: Could you please provide a reproducible scenario where you feed NT got stuck so we could look into? Thanks in advance

    Leave a comment:


  • NinjaTrader_Dierk
    replied
    @Harry: Could you please provide a reproducible scenario where you feed NT got stuck so we could look into? Thanks in advance

    Leave a comment:


  • r2kTrader
    replied
    Cunparis,

    Yes, testing for data would be key here. But that does not mean that the feed will send whether or not it has the data? So it may work with some data providers and not others.

    Some type of timeout in options would seem fitting. I know the issue you are talking about.


    Originally posted by cunparis View Post
    For me the main problem on this crashing and getting stuck downloading data is that one cannot tell if NT is going to successfully download the data or if it's going to be hung all day.

    Couldn't the loading data dialog show some kind of progress? Couldn't it check to make sure the data is available before getting stuck? Like if my data provider has data from 5/2006 to present and I accidently demand 1/2006 to present (which is my case right now as I type this) then the loading dialog just hangs forever. So I have to exit and restart. If NT would just ask the data provider if there is data from 1/2006 it could reply no and NT could return with a msg "no data for 1/2006". ????

    I have to exit and restart NT often because I mess up with my dates. it's very frustrating.

    Leave a comment:


  • Harry
    replied
    Please, fix the bug!

    The only way to check, whether it is still loading, is to look at the processor load within the task manager. If nothing happens any more, you better shut down NinjaTrader. Then go back to the task manager again, kill the NinjaTrader.exe process, which is still running on its own. Then try again, and it might work.

    To the developpers: NT is a really professional piece of software, which I love to use. But I wonder why you would not acknowledge that there is a major bug that locks NT every day. Come on, take the challenge! First accept that there is a bug (several users do confim it), now fix it, please!

    Leave a comment:


  • cunparis
    replied
    For me the main problem on this crashing and getting stuck downloading data is that one cannot tell if NT is going to successfully download the data or if it's going to be hung all day.

    Couldn't the loading data dialog show some kind of progress? Couldn't it check to make sure the data is available before getting stuck? Like if my data provider has data from 5/2006 to present and I accidently demand 1/2006 to present (which is my case right now as I type this) then the loading dialog just hangs forever. So I have to exit and restart. If NT would just ask the data provider if there is data from 1/2006 it could reply no and NT could return with a msg "no data for 1/2006". ????

    I have to exit and restart NT often because I mess up with my dates. it's very frustrating.

    Leave a comment:


  • NinjaTrader_Dierk
    replied
    AFAIK this is not possible with our current forum software.

    Leave a comment:


  • KBJ
    replied
    Originally posted by NinjaTrader_Dierk View Post
    The 20 secs limitation is to prevent robots attacking our forum. We will not eliminate that limitation for now.
    Could this limitation be lifted for a user who is currently signed in to the forum?

    I'd think most robots wouldn't sign in.

    Or maybe make searching without delay OK for users who have contributed 400 or more postings to the forums?

    Leave a comment:


  • NinjaTrader_Dierk
    replied
    The 20 secs limitation is to prevent robots attacking our forum. We will not eliminate that limitation for now.

    Leave a comment:


  • r2kTrader
    replied
    Jason,

    I have posted a few more times about this forum's search limitations. I just can't take the pain anymore. Particularly after being told the 20 secs would be removed. I can't search for small search terms? I have to wait 20 secs?

    It's pretty annoying to say the least . I am now using google to search the forums and that is pretty sad. Particularly because it will skew Ninja's ability to see keywords searched from the forum and realize that they need to allow shorter search terms!! lol. I give up.

    If anyone is interested, here is what you type into google's search bard to do searches.

    (without the ()'s)

    (20 seconds site:http://www.ninjatrader-support2.com/vb/)

    This will search for the term "20 seconds" (without "'s) on this forum. You also don't have to wait 20 seconds between searches. It's only been since I was told this would be checked into, lol.

    It's now Feb of the new year and I recently was told it was being removed. It's still there!! NT, please, save us from the pain!

    Anyway, I'll use Google for now unfortunately. But waiting patiently.

    PS, NT is awesome!



    Originally posted by NinjaTrader_Jason View Post
    Hi r2kTrader,

    As stated in the response I have sent you, we are aware of the limitations of our Support Forum and currently are looking into options on how they can be overcome.

    We will let you know when this will be changed.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by Scotty33, Today, 06:23 AM
0 responses
7 views
0 likes
Last Post Scotty33  
Started by Johnny90, Today, 04:19 AM
0 responses
16 views
0 likes
Last Post Johnny90  
Started by jeanne, Today, 03:43 AM
0 responses
13 views
0 likes
Last Post jeanne
by jeanne
 
Started by constituyente, Today, 02:37 AM
0 responses
6 views
0 likes
Last Post constituyente  
Started by HinduMVP, Yesterday, 09:50 PM
0 responses
10 views
0 likes
Last Post HinduMVP  
Working...
X