Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

MBT AUDUSD spread problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    MBT AUDUSD spread problem

    NT CS,

    I'm testing NT using MBT (demo) feed on AUDUSD and noticed that the spread is wildly different.

    When I place an order the spread will often be 80-100 pips (using 5 decimals), where the "ShowBidAsk" Indi shows a reasonable 18 pip spread.

    I have just check other pairs on NT on and they look reasonable.

    Is this a NT issue? or NT/MBT API issue? I am using the custom MBT build (if that makes any difference)

    Sorry forgot, also checked MBT navigator directly on the spreads and its floating around 20 pips.

    Thanks in advance.

    #2
    vincetc, welcome to our forums - which MBT navigator version do you use? We currently recommend 11.2.0.2 - http://www.ninjatrader.com/webnew/support_MB.htm

    Additionally please make sure you use the 'TenthPip' option for the 'Quote Currencies in' setting under Tools > Options > Misc.
    BertrandNinjaTrader Customer Service

    Comment


      #3
      Hi Bertrand,

      Thanks for the response. Can confirm that I am using the MBT nav ver 11.2.0.2 and have previously enabled the 1/10 pip option.

      I just tried again and got a 9`1 spread, as I mentioned earlier, this only happens on the AUDUSD pair, the other pairs I am testing in my currency basket do not have this problem.

      BTW, everything else in the platform is great (but might help to reduce system resource usage).


      cheers,
      Vince

      Comment


        #4
        Vince, thanks for the reply - checked my MBT connection and get the spreads as indicated on the MBT website, around 1.7 - 1.9 pip spread for AUSUSD currently. Where do you place the order and which window do you use to check for the spread and quotes? I just compated MBT Navigators FX board to my Control Center in NinjaTrader.
        BertrandNinjaTrader Customer Service

        Comment


          #5
          Hi Bertrand,

          I am placing the orders manually on "chart trader", there is no ATM running.

          I am using the the "ShowBidAsk" Indi (I got it from this forum) to see spread before placing the order. The indi is also showing a spread under 2.0. Which is the same as MBT Nav.


          Once I place the manual order, I immediately get a much larger spread.

          I took a screen shot of an order just placed manually, it immediately had a -8.2 pips on the PnL within the chart trader (shows -4.2 because i didn't grab the screen shot immediately,but you can see where the order was placed and also see from the ShowBidAsk indicator that the spread should have been approx 1.5.

          Cheers,
          Vince
          Attached Files

          Comment


            #6
            vincetc, thanks have not run into this, of course spreads change throughout the day...which order type are you placing on ChartTrader?
            BertrandNinjaTrader Customer Service

            Comment


              #7
              Hi Bertrand,

              All orders are placed by either "Buy Market" or "Sell market", so even taking into account slippage shouldn't be anywhere near -8.2 spread.......oh, nearly forgot, orders are not placed during/around major news events, so spread should be stable between 0.8-2.0.

              the orders are always placed during periods of reasonable liquidity and (90% of my FX trades are intraday, so it's shouldn't be a gap issue) and the fill seem quick , so still not sure why this is happening....

              If it helps, I also use yen, swiss and euro pairs and those manual orders are working fine.

              Cheers,
              Vince

              Comment


                #8
                I agree Vince, this spread is too high, tried reproducing it with a live and demo account, but paid only the ask in both cases while using market orders to get in (about 1.9 pip spread). Have you tried this on the newest NinjaTrader release 6.5.1000.11 yet? This was released yesterday and you can download it by going to Help > Download Site in the software.
                BertrandNinjaTrader Customer Service

                Comment


                  #9
                  Hi Bertrand,

                  Just tried the new release, did a complete uninstall before downloading and installing the latest version same issue occurs for the aussie, whilst other pairs are operating fine..........everything looks fine until i place an order, tonight it seems to have an immediate spread of 8.0 (regardless of how I place the order)

                  I can only assume that there is a minor bug within the MBT API which misinterprets the aussie spread when an order is placed (as MBT Nav is showing the correct spread when an order is placed via MBT Nav).......could this be the cause? or am I just randomly pointing fingers (at anyone else but me.....LOL)

                  In my frustrated state, I can only wait and see if NT7 (or a new version of MBT Nav /API) can resolve my problem.

                  Apart from the above issue, I think NT is a great product and very interested in migrating to NT for my live trading (assuming I can resolve this problem or just use a different currency to hedge) and even started to recode my indi's and EA from MQ4 to Ninja Script...............NT CS has been pretty good also.

                  Cheers,
                  Vince

                  ps. anyone else using MBT for your datafeed and NOT encountering a similar problem, I would appreciate knowing that it just something I am doing wrong......not the MM out to get me (just joking!)

                  Comment


                    #10
                    Vince, thanks for the kind words and sorry we had not yet found a solution why this occurs on your end - if you want me to test this on my end with your MBT logins, please contact me at support at ninjatrader dot com Attn Bertrand.
                    BertrandNinjaTrader Customer Service

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by Renorail, Today, 01:38 PM
                    2 responses
                    8 views
                    0 likes
                    Last Post bltdavid  
                    Started by BrianARice, Today, 01:16 PM
                    0 responses
                    5 views
                    0 likes
                    Last Post BrianARice  
                    Started by Ousher, Today, 09:08 AM
                    0 responses
                    6 views
                    0 likes
                    Last Post Ousher
                    by Ousher
                     
                    Started by Unsuitable, Today, 08:41 AM
                    0 responses
                    14 views
                    0 likes
                    Last Post Unsuitable  
                    Started by newdill, Today, 07:54 AM
                    0 responses
                    8 views
                    0 likes
                    Last Post newdill
                    by newdill
                     
                    Working...
                    X