• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NT hangs on Splashscreen

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    NT hangs on Splashscreen

    Hi,
    recently i have started to experience NT hanging on the splashscreen with the message that it is restoring the workspace.
    It sits there forever, until i kill it. On the second start attempt it will often come up but the workspace will be lost.

    I have searched the forum and noticed others seem to have the same issue. For some users the problem seems to have been related to some kind of 3rd party utility (Asus Driver, HP Printer driver where those i have found). I do not have an ASUS board neither an HP printer, and i´m puzzled what the root cause of the issue could be.

    I am wondering if Ninjatrader support have been able to delinate this? Any hints would be appreciated.

    #2
    Hello toulouse-lautrec,

    I suggest to delete the workspace that loads upon start-up and have an empty Default workspace load upon start-up.

    While NinjaTrader is closed, please go to My Documents-->NinjaTrader and delete the workspace that loads upon start-up.

    Start NinjaTrader and ensure your Default workspace is opened on your monitor. Close any workspace you might have loaded in the background.

    Please go to File-->Workspaces and check what workspaces are listed below 'Save Workspace As'. The workspace with the checkmark is the workspace opened on your monitor. Any additional workspaces listed, are opened in the background.

    Select a workspace without a checkmark and subsequently go to File-->Workspaces-->Close Workspace. Repeat this process until only the Default workspace is opened.

    Close NinjaTrader.

    Reboot your PC and check if NinjaTrader loads the initial attempt.

    Once NinjaTrader is started you can load workspaces via File-->Workspaces-->Open Workspace.
    JasonNinjaTrader Customer Service

    Comment


      #3
      Jason, thanks a lot for the prompt reply.
      Of course i have already deleted the workspace directory contents and started from scratch, but the problem persisted. I only have one workspace, and i don't save into default.
      I actually find myself deleting the contents of the workspaces folder often to be able to start up.

      I also already deinstalled NT including removal of the Documents/NinjaTrader 6.5 folder, and went back to an older version (.10).
      Seems there is no difference.

      So far no joy.

      Comment


        #4
        Hello toulouse-lautrec,

        Am I correct, the workspace you use loads upon start-up?

        If so, please have NinjaTrader load an empty Default workspace upon start-up instead of the workspace you use. Open the workspace via File-->Workspaces-->Open Workspace once the software is started.
        JasonNinjaTrader Customer Service

        Comment


          #5
          Jason, yes the WS loads on startup ... l

          anyways, i think i am seeing an improvement - i have removed the following programs from my system and hopefully one of them was the culprit:
          - Apple Mobile Device Support
          - Bonjour
          - Nvidia 3d ....

          Names of the programs are from memory, probably not 100% correct

          So far so good - have shutdown and restartedb Ninjatrader a few times with my WS coming up - knock on wood.

          I will post here if the problem returns.

          Comment


            #6
            Unfortunately the problem reappeared today when starting up NT.
            I closed my workspace yesterday before shutting down NT, leaving only the default WS open. My default workspace has only one chart on it with a 1 min of the ES, no indicators.

            Today when starting NT it was just hanging at "restoring workspace Default"



            Killed the process, started NT again and it came up fine with an empty default WS.

            Today i will do the same as yesterday, closing my WS before shutting down, but leaving my default WS empty.

            I´ll keep you posted.

            Comment

            Latest Posts

            Collapse

            Topics Statistics Last Post
            Started by manueldecastro, Today, 12:57 AM
            0 responses
            5 views
            0 likes
            Last Post manueldecastro  
            Started by JulieG, Today, 12:40 AM
            0 responses
            5 views
            0 likes
            Last Post JulieG
            by JulieG
             
            Started by jimjoe123, Yesterday, 09:28 PM
            2 responses
            12 views
            0 likes
            Last Post NinjaTrader_ChrisSch  
            Started by 12VMan, 08-20-2019, 09:29 AM
            2 responses
            25 views
            0 likes
            Last Post Lancer
            by Lancer
             
            Started by tgn55, Yesterday, 09:50 PM
            0 responses
            5 views
            0 likes
            Last Post tgn55
            by tgn55
             
            Working...
            X