• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Bug? Problem with import data from textfile

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by NinjaTrader_Brett View Post
    Hello,

    Its

    2) NT assigns a timestamp based on the selected timezone when importing. Then I should see different dates and times depending on the timezone setting at import.


    It will by default set a time stamp of 24:00. However is I for example add the offset based on the timezone selected. Based on EST.

    Therefor, if I set MTN time zone which is two hours - EST. I get a time stamp of 22:00.

    Therefor you need to adjust your Import time zone to match the time of your other data.

    Let me know if I can be of further assistance.
    Interesting, because I don't see that happening! The time never changes regardless of the timezone that I select for import. However the DATE will change at some point. How can the date change but not the time?

    Just to be clear: you actually DO see a different time when you change the timezone while IMPORTING data? (as opposed to changing the timezone of your PC).

    Comment


      #17
      Hello,

      In my testing a had selected the same time zone as my PC. This duplicated these results.

      Its seems it actually adds at 12:00 Time stamp that is offset by your PC clock. Not your selected timezone of the improted data. This is specific to daily data only.

      Therefor you would need to change your local PC time stamp. Restart NinjaTrader and then import this data in.

      Let me know if I can be of further assistance.
      BrettNinjaTrader Product Management

      Comment


        #18
        What you mention here is a WORKAROUND, but I still consider this a bug. If NT is ignoring the timezone setting of the Historical Data Manager, it should ignore it COMPLETELY and NEVER make a shift in the DATE! Now it is actually doing a conversion at import (and it should), but is is doing it incorrectly.

        Here is how it is supposed to work:
        NT doesn't find a time in the time in the file so it will set it at 00:00. But when I tell the Historical datamanager that the data originates from a +7 hrs timezone, it should adjust this timestamp to 17:00.

        The current bug makes it impossible to EVER align two EOD series properly without doing workarounds like messing with the Windows timezone settings. You should never have to do that. And NT has a built in capability to take care of that (in the historical data manager). I can see that because the historical datamanager will sometimes change the DATE (but never the time). So it IS actually trying to do a timestamp correction at import.

        In other words, the functionality is there but a bug prevents it from working properly!

        I suggest you discuss this with one of your collegues to check if he agrees that this is a bug of not. In my opinion it most definately is!

        Thank you for your support.

        Comment


          #19
          Hello,

          I understand your concearn, However the question I asked earlier is why are you exporting the data and then importing it back in?

          Thank You.
          BrettNinjaTrader Product Management

          Comment


            #20
            Originally posted by NinjaTrader_Brett View Post
            Hello,

            I understand your concearn, However the question I asked earlier is why are you exporting the data and then importing it back in?

            Thank You.
            To test if the fact that imported data is not aligned is indeed a bug or somehow caused by the input data. By exporting the same data and then importing it back in using different timezone settings in the Historic Data Manager I was able to confirm that it is indeed a bug.

            If things work properly in NT, I should always be able to find a setting of the timezone that makes the data align properly. This is unfortunately not the case.

            Comment


              #21
              Hello,

              Ok, I will check into this to see if there is something that can be done.

              You will not get an update until Tuesday on this as this is when development will be back in.

              Let me know if I can be of further assistance.
              BrettNinjaTrader Product Management

              Comment

              Latest Posts

              Collapse

              Topics Statistics Last Post
              Started by cocopod, Today, 05:32 AM
              1 response
              2 views
              0 likes
              Last Post sledge
              by sledge
               
              Started by Leeroy_Jenkins, Today, 03:52 AM
              2 responses
              14 views
              0 likes
              Last Post Leeroy_Jenkins  
              Started by Leope, Today, 03:15 AM
              1 response
              6 views
              0 likes
              Last Post NinjaTrader_ChrisSch  
              Started by Frook1951, Today, 03:09 AM
              0 responses
              5 views
              0 likes
              Last Post Frook1951  
              Started by unlobotrader, Today, 02:46 AM
              0 responses
              6 views
              0 likes
              Last Post unlobotrader  
              Working...
              X