NinjaTrader Support Forum

NinjaTrader Support Forum (http://www.ninjatrader.com/support/forum/index.php)
-   Historical NinjaTrader 6.5 Beta Threads (http://www.ninjatrader.com/support/forum/forumdisplay.php?f=42)
-   -   Bars are wrong on strategy performance (negative bars) (http://www.ninjatrader.com/support/forum/showthread.php?t=4960)

woodside 01-13-2008 08:54 PM

Bars are wrong on strategy performance (negative bars)
 
1 Attachment(s)
Getting some strange "bars" results on running a "historical and real-time" performance on a running strategy. See the attached graphic, trade 2 and 3 are wrong. This is a strategy running on 1 minute bars.

This is with the latest beta, downloaded tonight.

-Erik

woodside 01-13-2008 09:04 PM

1 Attachment(s)
Related to the above post, in my strategy I have the following code to wait 15 bars before entering a trade after exit. This seems to work fine in real time, but in back testing it doesn't. Using the following in my multi period strategy:

&& (BarsSinceExit(0,"ShortLimit", 0) > 15 || BarsSinceExit(0,"ShortLimit", 0) == -1 )

If you look at trades 7 and 8, trade 8 entered before trade 7 closed, and when I do a right-click chart of trade 7, it doesn't appear, only trade 8. See attached chart.

NinjaTrader_JoshP 01-13-2008 11:22 PM

Hmm. Could you send me a simple as possible strategy that highlights the issues you are experiencing? I would like to run some tests based on your environment. Thanks for the help.


All times are GMT -6. The time now is 03:20 PM.