• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

IB warning that version 960.2g needs to be upgraded

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    IB warning that version 960.2g needs to be upgraded

    Hi NT,

    As everybody knows IB's TWS 960.2g is the version that you have set as the latest compatible and stable to use with Ninjatrader7. The problem is this morning I've received a warning that this version must be upgraded by April 2020. I've written to Interactive Brokers to ask several questions for more info, such as it will stop totally, is it just support...etc. As soon I got answers, I'll post it here. Nevertheless, as you must know, there are a lot of us, seniors old clients with lifetime licenses, that still work with real accounts, because Ninjatrader 7 has good features for automated algorithms such as light memory use, fast charts, almost never freeze...etc that makes our work almost uneventful.

    Please address this important issue.
    Looking forward to your answer.
    Thanks for your attention

    #2
    Hello pstrusi,

    Thank you for your note.

    While we do not have an announcement to provide on this item at this time, there is an existing feature request on this item and I have submitted your vote to our development team for this request.

    Please let us know if we may assist further.
    Chris Sch.NinjaTrader Customer Service

    Comment


      #3
      Hi Chris,

      Thanks for your quick answer and I appreciate your attention to this. However, this matter is not a feature, it's an urgent need for all of us that work with the tandem Ninjatrader7-IB, because IB is warning that the old TWS version 960.2g needs to be upgraded by April 2020. We should not take the risk that by that time, we can't work anymore because Ninjatrader hasn't been able to work with a version, at least some superior to 960.2g.

      Please, Consider this matter as urgent and scale it up to Developers that for sure know of this Critical subject. This is critical, not just a feature.

      I hope this can be worked out as soon as possible
      Thanks

      Comment


        #4
        Chris, I've received answer from IB, it's more serious than thought. Here you can read it, so you can scale up this urgent matter:


        Summary: TWS old version working with Ninjatrader
        pier..... 2020/02/26 04:35:14
        Since I work with my automated algorithms through the platform Ninjatrader ( version 7 ), I have to use an old version of TWS ( 960.2g ). The problem is this morning I've received a warning from you in the TWS, that this version needs to be upgraded by April 2020. So, I have questions:

        1. Will this old version stop working by April 2020 ?
        2. Is it simply that this version will continue to work but without any further support?

        Looking forward to your answers
        Thanks for your attention
        IBCS 2020/02/26 08:40:56
        Dear Mr. Strusi,

        Starting April 2020 we will block all login access to TWS which are using older builds such as 960.2g. NT8 already supports a newer version. It would be advised to discuss this with Ninja Trader to see if they can update support for NT7 on a newer build.


        Regards,
        Angel P.
        IBKR
        API Support, Technical Assistance Center

        Comment


          #5
          Since I received this morning a warning from IB that TWS old version 960.2g needs to be upgraded, quickly I asked them a couple of questions, below you can read the answer.

          This is matter that requires urgent action from the Development Team as soon as possible!!!.

          I began this post with a previous one: https://ninjatrader.com/support/foru...to-be-upgraded



          ANSWER
          Summary: TWS old version working with Ninjatrader
          pier..... 2020/02/26 04:35:14
          Since I work with my automated algorithms through the platform Ninjatrader ( version 7 ), I have to use an old version of TWS ( 960.2g ). The problem is this morning I've received a warning from you in the TWS, that this version needs to be upgraded by April 2020. So, I have questions:

          1. Will this old version stop working by April 2020 ?
          2. Is it simply that this version will continue to work but without any further support?

          Looking forward to your answers
          Thanks for your attention
          IBCS 2020/02/26 08:40:56
          Dear Mr. Strusi,

          Starting April 2020 we will block all login access to TWS which are using older builds such as 960.2g. NT8 already supports a newer version. It would be advised to discuss this with Ninja Trader to see if they can update support for NT7 on a newer build.


          Regards,
          Angel P.
          IBKR
          API Support, Technical Assistance Center

          Comment


            #6
            pstrusi , I've merged your newer topic on the same issue to your original thread. This will help us keep issues organized and not fragmented by specific topic.

            As my colleague stated, the Development Team is aware of this upcoming change and will act accordingly. In the meantime, as Interactive Brokers support stated, you could begin using the version we currently support for NinjaTrader 8 which is 973.2:When there is any further update, there will be an announcement made.
            Patrick G.NinjaTrader Customer Service

            Comment


              #7
              Hi Patrick, noted. I'm aware that not fragmenting Posts related, however, I felt necessary to post the new one with the URGENT word, because it's urgent cause the response from IB. This post title shows no urgency as it was a normal issue with no rush.

              Now a question: What if I still need to work with Ninjatrader 7? There're many of us that we're not totally agreed to use Ninjatrader 8 cause many reasons. I hope better DevTeam can solve the issue.

              Thanks
              Last edited by pstrusi; 02-26-2020, 09:00 AM.

              Comment


                #8
                Support for NinjaTrader 7 in general is not going away. When that occurs, there will be a major announcement with plenty of warning time for NinjaTrader 7 users to make the transition. The only change in this specific instance is the need to use a different version of TWS.
                Patrick G.NinjaTrader Customer Service

                Comment


                  #9
                  That's exactly right. There's a critical need to know what TWS version we could move to. It'd be great when DevTeam has figured that out and tell us. It'll be great to read the solution.

                  Comment


                    #10
                    The version that will most likely end up being the supported version for NinjaTrader 7 is the currently supported version for NinjaTrader 8. I'd advise that you do this sooner or later and contact us if there are any unexpected behaviors seemingly onlycaused by using TWS 973.2 instead of TWS 960:

                    Originally posted by NinjaTrader_PatrickG View Post
                    pstrusi
                    ...you could begin using the version we currently support for NinjaTrader 8 which is 973.2:
                    Patrick G.NinjaTrader Customer Service

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by b16_aln, Today, 12:47 AM
                    0 responses
                    1 view
                    0 likes
                    Last Post b16_aln
                    by b16_aln
                     
                    Started by mbcmbc, Yesterday, 11:01 PM
                    0 responses
                    3 views
                    0 likes
                    Last Post mbcmbc
                    by mbcmbc
                     
                    Started by morrnel, Yesterday, 09:39 PM
                    0 responses
                    1 view
                    0 likes
                    Last Post morrnel
                    by morrnel
                     
                    Started by Thesuccesfulinvestor, Yesterday, 09:07 PM
                    0 responses
                    6 views
                    0 likes
                    Last Post Thesuccesfulinvestor  
                    Started by WestonMicah, Yesterday, 12:44 AM
                    1 response
                    17 views
                    0 likes
                    Last Post koganam
                    by koganam
                     
                    Working...
                    X